Unable to run struts project from jdeveloper 10.1.3

October 11 1
Advertisement
Hi,
I have created a struts-based application project using jdeveloper 10.1.3(build JDEVADF_10.1.3.1.0_NT..) by importing an ear file .The project seems to be built fine as i get no errors in compiling the entire project.I have included the Struts runtime library as well in the project.
But when i try to run the login.jsp from the struts-config.xml,i get the :
The page cannot be displayed message in the browser.
I dont see any errors in the Embedded OC4J log except few warnings lik dis:
[Another instance of the server is still running.  JDeveloper will shut it down and then restart the server.]
Process exited.
[Starting OC4J using the following ports: HTTP=8898, RMI=23899, JMS=9235.]
D:\jdevr12\jdevhome\jdev\system\oracle.j2ee.10.1.3.39.81\embedded-oc4j\config>
D:\jdevr12\jdevbin\jdk\bin\javaw.exe -client -classpath D:\jdevr12\jdevbin\j2ee\home\oc4j.jar;D:\jdevr12\jdevbin\jdev\lib\jdev-oc4j-embedded.jar -Xverify:none -DcheckForUpdates=adminClientOnly -Doracle.application.environment=development -Doracle.j2ee.dont.use.memory.archive=true -Doracle.j2ee.http.socket.timeout=500 -Doc4j.jms.usePersistenceLockFiles=false oracle.oc4j.loader.boot.BootStrap -config D:\jdevr12\jdevhome\jdev\system\oracle.j2ee.10.1.3.39.81\embedded-oc4j\config\server.xml
[waiting for the server to complete its initialization...]
25-Jul-2007 18:46:28 com.evermind.server.jms.JMSMessages log
INFO: JMSServer[]: OC4J JMS server recovering transactions (commit 0) (rollback 0) (prepared 0).
25-Jul-2007 18:46:28 com.evermind.server.jms.JMSMessages log
INFO: JMSServer[]: OC4J JMS server recovering local transactions Queue[jms/Oc4jJmsExceptionQueue].
WARNING: Code-source D:\jdevr12\jdevbin\jdev\appslibrt\xml.jar (from <library> in /D:/jdevr12/jdevhome/jdev/system/oracle.j2ee.10.1.3.39.81/embedded-oc4j/config/application.xml) has the same filename but is not identical to /D:/jdevr12/jdevbin/lib/xml.jar (from <code-source> (ignore manifest Class-Path) in META-INF/boot.xml in D:\jdevr12\jdevbin\j2ee\home\oc4j.jar). If it contains different versions of the same classes, it will be masked as the latter is already visible in the search path of loader default.root:0.0.0.
WARNING: Code-source D:\jdevr12\jdevbin\jdev\appslibrt\jazn.jar (from <library> in /D:/jdevr12/jdevhome/jdev/system/oracle.j2ee.10.1.3.39.81/embedded-oc4j/config/application.xml) has the same filename but is not identical to /D:/jdevr12/jdevbin/j2ee/home/jazn.jar (from <code-source> in META-INF/boot.xml in D:\jdevr12\jdevbin\j2ee\home\oc4j.jar). If it contains different versions of the same classes, it will be masked as the latter is already visible in the search path of loader default.root:0.0.0.
WARNING: Code-source D:\jdevr12\jdevbin\jdev\appslibrt\jazncore.jar (from manifest of /D:/jdevr12/jdevbin/jdev/appslibrt/jazn.jar) has the same filename but is not identical to /D:/jdevr12/jdevbin/j2ee/home/jazncore.jar (from <code-source> in META-INF/boot.xml in D:\jdevr12\jdevbin\j2ee\home\oc4j.jar). If it contains different versions of the same classes, it will be masked as the latter is already visible in the search path of loader default.root:0.0.0.
WARNING: Code-source D:\jdevr12\jdevhome\jdev\system\oracle.j2ee.10.1.3.39.81\embedded-oc4j\applications\datatags\webapp\WEB-INF\lib\uix2.jar (from WEB-INF/lib/ directory in D:\jdevr12\jdevhome\jdev\system\oracle.j2ee.10.1.3.39.81\embedded-oc4j\applications\datatags\webapp\WEB-INF\lib) has the same filename but is not identical to /D:/jdevr12/jdevbin/jdev/appslibrt/uix2.jar (from <library> in /D:/jdevr12/jdevhome/jdev/system/oracle.j2ee.10.1.3.39.81/embedded-oc4j/config/application.xml). If it contains different versions of the same classes, it will be masked as the latter is already visible in the search path of loader datatags.web.webapp:0.0.0.
Ready message received from Oc4jNotifier.
Embedded OC4J startup time: 26766 ms.
pls help me out on what could be the problem.This application wsa running fine in Eclipse but i am unable to run it using Jdeveloper.
Advertisement
Is this new develop page ?
you check these points for this issue.
1. Check JDEV_USER_HOME
2. Design a Test PG and test it first.
3. Your OAF patch level: is 12.0.4 ? Are you running with r12?
Thanks