Mapping tested successfully in Simulator but fails in SXI_MONITOR

October 11 0
Advertisement
Hi gyus,
The Outbound message structure is the following:
MT_CAP_BANKS
actions     1..1    xsd:string
RECORD   0..unbounded  Segment
   Field1
   Field2
   etc
The target Inbound message structure is the structure of the JDBC receicer adapter, since the scenario is Proxy to JDBC.
MT_DB_BANKS
STATEMENT       1..unbounded
DBSTATEMENT   1..1
   action
   etc
I want to have one STATEMENT per RECORD segment. But the RECORD segment may also be missing in case that we want to do massive delete of all the entris in a table. So I may have only the action field in some test cases.
Therefore, I am mapping RECORD>mapWithDefault>STATEMENT.
Mapping is tested successfully in simulator for all cases, either many RECORD segment or no RECORD segment. Interface mapping tested successfully. However, when we are doing real tests, mapping works fine with many RECORD segments, but fails with no RECORD segments (Cannot produce target element /ns0:MT_DB_BANKS/STATEMENT. Check xml instance is valid for source xsd and target-field mapping fulfills requirements of target xsd).
Any ideas ?
I also tried to chang the mapping with IF RECORD EXISTS THEN STATEMENT='' ELSE RECORD-->STATEMENT but problem still remains!!
Advertisement
Hi,
I'm not really sure why you are encountering this error. Have you tried any context modifications before mapping to field STATEMENT?
Could you try this mapping?
constant:null -----------------------------------------> \
RECORD --> mapWithDefault:null --> equalsS:null --> ifThenElse --> STATEMENT
constant:hasValue -------------------------------------> /
The code should perform just like the one with the mapWithDefault without the ifThenElse, but it's worth to try.
Hope this helps,
Mapping tested successfully in Simulator but fails in SXI_MONITOR

Hi gyus, The Outbound message structure is the following: MT_CAP_BANKS actions     1..1    xsd:string RECORD   0..unbounded  Segment    Field1    Field2    etc The target Inbound message structure is the structure of the JDBC receicer adapter, since

ERROR:Simulator:861 - Failed to link the design

hi i'm a very new student user of xilinx 14.2 design tool who just used it 2 weeks. this week i should do "Simulate Behavioral Model" but i can't.... just i saw below messages.. and i don't know what is the matter. Started : "Simulate Behav

Simulation engine failed to start: A valid license was not found for simulation

Hi, I'd like to run xsim by clicking "Run Simulation" in Vivado 2015.2 . However, in the Tcl console I see this error: INFO: [Common 17-186] '/home/rob/xilinx-projects/bright_proj/bright_proj.sim/sim_1/behav/xsim.dir/ProgNetwork_behav/webtalk/us

What is the source of this Crawl Error `The item could not be indexed successfully because the item failed in the indexing subsystem`

Once in a while my full-crawl fails and stops working properly. The crawllogs show this error for all items crawled. The item could not be indexed successfully because the item failed in the indexing subsystem. ( The item could not be indexed success

I bought an Adobe photoshop elements 12 and successfully installed. I failed to activate as it said I am offline whereas I am online. I tried offline activation but failed. Could someome help me? Thanks

I bought an Adobe photoshop elements 12 and successfully installed. I failed to activate as it said I am offline whereas I am online. I tried offline activation but failed. Could someome help me? ThanksHi Agathe, Please refer to the below link and fo

Ocrcheck success on node1 but failed on node2.(11gR2 for Windows)

Hi all , I have installed the Oracle Grid Infrastructure with ASM on windows 2008 x64, Everything is done without any error, but ocrcheck failed on nodde2. detail is below: checking commnds on node 1: *>crsctl check crs* CRS-4638: Oracle High Availab

The item could not be indexed successfully because the item failed in the indexing subsystem. ( The item could not be indexed successfully because the item failed in the indexing subsystem.; Caught exception when preparing generation GID[351]: (Indexer fa

Hi guys, I'm getting this error from the crawler. Any ideas at all what might be causing it? The item could not be indexed successfully because the item failed in the indexing subsystem. ( The item could not be indexed successfully because the item f

Interface mapping test successful, throws exception in BPM

Hi. We are having a problem with an Interface mapping which works when tested in Integration Builder, but throws an Exception when it is part of the Transformation in a BPM. The scenarion is such: 1. The sender calls the outbound interface using a we

Control & Simulation Loop failed to compile

Dear Forum Members, I have a problem with a Control & Simulation Loop program (attached) that just doesn't compile & run.  I believe that the problem is associated with the 'Feedback Node' at the bottom of this Control & Simulation Frame since

OWB 10.2 Phantom Phailures - mapping reports success but no data!

Hi all, I've been getting more and more mapping jobs that run for their normal duration but do not update anything in OWB 10.2 against a 10.2 database. I see the following symptoms: 1. The finish time is set to the start time of the mapping when this

N97 Mini Map Loader using Mac OS X failed to load ...

Nokia N97 Mini S/W v 12.0.110 Nokia Maps Loader 1.0 (770) on Mac OS X 10.6.4 I'm trying to load map for INDIA (121.1 MB). While in progress, the software shows me a message "52f40.cdt: File couldn't be uploaded. The file or folder might be in use&quo

Acrobat XI Pro successfully installed, but it failed in converting word files into PDF, why?

I just installed Adobe XI Pro through the download assistant, it looks the installation went well, but when I tried to convert word files into PDF (tried many times), it failed. Anyone has the same problems, any solutions?Please reply with more infor

IPhoto upload error for printing. First two books successful. This one fails.

I have successfully developed two iPhoto books in the past, however, the third book goes through the entire process of uploading and then indicates 'error'. This book is 46 pages long which should not be a problem. Any suggestions? Thank you. Phil G,

Email sent successfully in foreground,but fails in background

Dear All, On Tcode FBL5N, i have an option to send the account statement to specific customers. the issue i am facing is happening only to ONE customer ABC when the program is scheduled to run as a batch, tONLY his customer ABC alone does not recieve

App runs fine in simulator but fails on iPad

My app has been running fine in the simulator environment but tried running for the first time on an iPad.  It loads the first screen (which is a table view) but if I try to do anything, including just scrolling the table, it crashes.  The Xcode orga

BlackBerry Z10 STL100-1 update Blackberry Maps 10.1.0.805 install failed

Device: BlackBerry Z10 Model: STL100-1 Software Release: 10.1.0.273 OS Version: 10.1.0.1720 Carrier: Beeline KZ Country: Kazakhstan 1. Update for BlackBerry Maps downloaded but not installed. What may be the problem? 2. Maps are not available for Kaz

Troja has taken over my new windows 7 computer and I cannot load Mozilla Firefox successfully - keeps saying it failed

I get it off with google and then it reappears, I bring it back to factory specs,hello, please run a full scan of your system with different security tools specialised in adware like the [http://www.malwarebytes.org/products/malwarebytes_free free ve

User authentication successful when it should fail?

Hello, we have a situation where a given user for example: Name: Jonas Surname: Valančiūnas SamAccountName: j.valanciunas can authenticate when loging on to computer by entering his SamAccountName like this: j.valančiūnas N.B. symbols "č" and &q

Iphone 4 upgrade to lastest version download success but restoring it failed

I tried to restore my iphone 4 after I upgrade to its lastest version, however it said error.  I looked through all the possible troubleshoot help.  None seems to work.Disable your firewall/security software/ani-virus and try againRead other 3 answer

Call Adapter failing in SXI_MONITOR

Hi Everyone, We have a scenario  = SAP HR ---> XI ---> Legacy systems designed.  proxies are used to send message from SAP HR and JDBC adapter is used in recevier side to update sql database. And working in live but suddenly it failed and got below